wamp 3.0.6(apache 2.4.23) 配置多站点

     之前开发机器上一直用着wamp2.2,php5.4.3也有点落后了,composer更新很多类都提示要升级php版本了,于是就下载了wampserver3.0.6,软件包200多M。apache2.4.23_mysql5.7.14_php5.6.25-7.0.10。安装之后php5.6,php7.0随意切换。有些项目是mysql的,还是乖乖用5.6吧,毕竟php7没有mysql驱动,可以用mysqli,pdo_mysql。推荐用PDO来操作数据库。

    注意:vc++ 2015要安装,没有的话apache跑不了。

    装完wamp3就要配置多站点了,apache2.4是要将其中的 Require local 修改成 Require all granted

blob.png

    因为我之前的是wamp2.2,很多项目还在之前的旧的目录,所以在apache2.4下授权旧的目录,这样就可以把原来的配置文件复制过来用了,目录授权之后DocumentRoot配置的路径也不用动。在httpd.conf里面属于全局配置,也可以在httpd-vhosts.conf里面单独配置。

blob.png

    最后重启apache。

在WAMPSERVER下增加多版本的PHP(PHP5.3,PHP5.4,PHP5.5)支持

WAMPServer可以让开发者在Windows系统下快速搭建WAMP环境,它支持多版本的Apache、MySQL、PHP之间的相互切换,互不影响,对于PHPer开发者来讲极为方便快速。

以下是在WAMPServer下同时支持PHP5.3、PHP5.4、PHP5.5、PHP5.6的步骤:

1、安装WAMPServer

根据自己的操作系统选择相应的WAMP版本,我这里选择WAMPSERVER-32 BITS & PHP 5.5-2.5,双击安装,选择安装目录即可,超级简单。

根据我安装的版本,这里已经默认安装了PHP5.5.12,如下图,可以发现多了两个特别文件:phpForApache.iniwampserver.conf

- 阅读全文 -